Johnny [Life & Code]

Semper Exploro!

Evolution MAPI : Debut tarball release & RPM Repos are online

with 16 comments

We have started the tarball releases for evolution-mapi. It’ll be in sync with GNOME release schedule. evolution-mapi-0.25.3 is available for download [0].

Thanks to Suman [1], openSUSE repositories [2] are back online.

Matthew has repositories for Fedora [3] [4]

—-
[0] http://ftp.gnome.org/pub/GNOME/sources/evolution-mapi/0.25/

[1] http://mail.gnome.org/archives/evolution-list/2008-December/msg00097.html

[2] http://download.opensuse.org/repositories/GNOME://Evolution://mapi/

[3] http://mbarnes.fedorapeople.org/mapi/

[4] http://mail.gnome.org/archives/evolution-list/2008-December/msg00086.html

Written by Johnny

December 15, 2008 at 1:08 pm

Posted in CODE, Evolution, GNOME, suse, Tech, Work

Tagged with

16 Responses

Subscribe to comments with RSS.

  1. […] zur Abwechselung nur mal eine kleine News. Wie ich gerade im Blog von Johnny gelesen habe: Die Repositorys für die RPMs vom Evolution-MAPI Plugin des OpenChange Projekts sind […]

  2. Hi, historically, I’ve been installing from svn on ubuntu 8.10, with my last install not functioning very well. My question is: how do we use these tarbals in terms of… is it a plugin, is it a full evolution replacement? Also, what are the dependencies? Is it based on an svn checkoout (which one) or a stable release?

    Nic

    December 16, 2008 at 10:08 am

  3. Yep these are plugin tarballs. Which means that you can installl these over a existing evolution installation.
    Dependancies : openchange 0.8 (that would require samba4). Evolution 2.24.1.1+ or 2.25.2+.
    The tarballs are from svn.gnome.org/svn/evolution-mapi/trunk.
    I’ll update go-evolution.org/MAPIProvider.

    Johnny

    December 16, 2008 at 12:04 pm

  4. I tried to install this on Ubuntu Intrepid but it looks like it requires a newer version of evolution-data-server than is available:

    checking for EVOLUTION_DATA_SERVER… configure: error: Package requirements (evolution-data-server-1.2 >= 2.25.2) were not met:

    Requested ‘evolution-data-server-1.2 >= 2.25.2’ but version of evolution-data-server is 2.24.2

    Bummer. I hope that someone will setup an Ubuntu PPA for these.

    -James

    James Ward

    December 23, 2008 at 2:04 pm

  5. @James : Open up configure.in and change the minimum requirement to 2.24.2. It would work for now🙂 .

    Johnny

    December 23, 2008 at 3:12 pm

  6. […] have a bit of an obsession with getting Ubuntu to work with MS Exchange 2007. On the website of Jonny Jacob I read that the started to publish source releases of the plugin. So I downloaded the source of the […]

  7. Why hello there, I seem to be having a dependency issue, I have libcamel and libcamel-provider installed on my system but the rpm for evolution-mapi seems to think I don’t.

    the particulars:

    –> Processing Dependency: libcamel-1.2.so.13 for package: evolution-mapi
    –> Processing Dependency: libcamel-provider-1.2.so.13 for package: evolution-mapi
    –> Finished Dependency Resolution
    evolution-mapi-0.25.3-1.fc10.i386 from evolution-mapi-0.25.3-1.fc10.i386.rpm has depsolving problems
    –> Missing Dependency: libcamel-provider-1.2.so.13 is needed by package evolution-mapi-0.25.3-1.fc10.i386 (evolution-mapi-0.25.3-1.fc10.i386.rpm)
    evolution-mapi-0.25.3-1.fc10.i386 from evolution-mapi-0.25.3-1.fc10.i386.rpm has depsolving problems
    –> Missing Dependency: libcamel-1.2.so.13 is needed by package evolution-mapi-0.25.3-1.fc10.i386 (evolution-mapi-0.25.3-1.fc10.i386.rpm)
    Error: Missing Dependency: libcamel-provider-1.2.so.13 is needed by package evolution-mapi-0.25.3-1.fc10.i386 (evolution-mapi-0.25.3-1.fc10.i386.rpm)
    Error: Missing Dependency: libcamel-1.2.so.13 is needed by package evolution-mapi-0.25.3-1.fc10.i386 (evolution-mapi-0.25.3-1.fc10.i386.rpm)

    /usr/lib/libcamel-1.2.so.14
    /usr/lib/libcamel-1.2.so.14.0.0
    /usr/lib/libcamel-provider-1.2.so.14
    /usr/lib/libcamel-provider-1.2.so.14.0.0

    these are supposed to be provided by evolution-data-server and I do have that installed. I also tried making a sym link to the so.14 version of the and calling it so.13 to see if I could fool it into installing but no luck.

    Didn’t know where to put this comment so I put it here😀

    bjaming

    December 30, 2008 at 8:05 pm

  8. Dude,

    You guys rock! Thanks for the links to the RPM’s. Going to give it a run later today!

    Keep up the “MUCH APPRECIATED” work!!

    Keith

    January 2, 2009 at 2:13 pm

  9. Hi Johnny,

    I have installed from Matthew’s repo, and I can see that it now support HTML mails, it displays the folders correct, BUT, I cannot send emails. All emails return from System Administrator saying that the email address does not exist. This is not true as that is my own email address.

    Oh, and for some reason, the error message returns in French…

    Any ideas?

    Keith

    January 2, 2009 at 3:45 pm

  10. Thank you for your work.

    I am having identical issues installing on Ubuntu 8.10. I have unpacked the RPM using alien but this is not working either. I just gives a not compatible error when connecting to Exchange.

    I am about 8 hours into trying to install the tarball and am getting the error listed above by James Ward. I have changed the versions in configure but with no luck.

    I know we will get there but any hints would be fantastic.

    I thought I may try installing Fedora and Open SUSE to see if these will work for now!!! To be honest I will try this when I have time.

    Really appreciate the work though!

    Ross

    January 2, 2009 at 10:12 pm

  11. Sorry. I have tried to install open suse tonight and it will not write to disc. I have installed Fedora and installed all packages except the mapi ones which refuse.

    I get

    libexchangemapi-1.0.so.0 is needed by package evolution-mapi-devel-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-devel-0.25.3-1.fc10.i386-2.rpm)
    evolution-devel >= 2.25.2 is needed by package evolution-mapi-devel-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-devel-0.25.3-1.fc10.i386-2.rpm)
    evolution-data-server-devel >= 2.25.2 is needed by package evolution-mapi-devel-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-devel-0.25.3-1.fc10.i386-2.rpm)
    evolution-mapi = 0.25.3-1.fc10 is needed by package evolution-mapi-devel-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-devel-0.25.3-1.fc10.i386-2.rpm)evolution-mapi-devel-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-devel-0.25.3-1.fc10.i386-2.rpm)

    and

    libcamel-1.2.so.13 is needed by package evolution-mapi-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-0.25.3-1.fc10.i386-3.rpm)
    libcamel-provider-1.2.so.13 is needed by package evolution-mapi-0.25.3-1.fc10.i386 (/tmp/evolution-mapi-0.25.3-1.fc10.i386-3.rpm)

    I have searched for libcamel but have just uninstalled most Gnome aplications trying to reinstall evolution-data-server.

    I am a little bored after 7 hours on a saturday night – I have been trying everything but have about given up hope. I just hope this gives you some useful feedback apart from some chump cant install the mapi extension.

    Sorry.

    and

    Ross

    January 4, 2009 at 12:48 am

  12. For those who want to test with Fedora 10
    —————————————

    You need to have evolution-2.52.x

    So before you try to install the RPM’s provided by Matthew, first install evolution-data-server and evolution from rawhide repo:

    (as root) yum –enablerepo=rawhide update evolution evolution-data-server

    Now you will be able to install the above rpms!

    As I noted before, I can successfully hook up to a exchange server and read mail, but can’t send. If anyone can find out why, please let me know! I will create a new thread on fedoraforum.org where evolution and mapi issues can be discussed!

    Keith

    Keith

    January 4, 2009 at 3:03 pm

  13. Sorry that command should be:

    yum –enablerepo=rawhide update evolution evolution-data-server (it should be 2 dashes in front of enablerepo)

    Keith

    January 4, 2009 at 3:06 pm

  14. @keith : Would be awesome if you can report the issues that you are facing in bugzilla.gnome.org under evolution-mapi. tia !🙂

    Johnny

    January 6, 2009 at 3:18 am

  15. @keith : I created a bugzilla entry : http://bugzilla.gnome.org/show_bug.cgi?id=566729 . Please provide information there. Or ping me on irc ‘jony’

    Johnny

    January 6, 2009 at 5:02 am

  16. Thanks Johnny!

    Will do!

    Keith

    January 6, 2009 at 12:20 pm


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: